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All rights in this manual and the program are reserved.  No part of the program or manual may be
copied, reproduced, stored or transmitted in any form or by any mechanical or electronic means
without the prior written consent of TechSoft UK Limited.

The program described in this manual is subject to continuous development and improvement.  All
information of a technical nature and particulars of the program and its use (including the informa-
tion and particulars in this manual) are given by TechSoft UK Limited in good faith.  However,
TechSoft UK Limited cannot accept any liability for any loss or damage arising from the use of any
information or particulars in this manual.

N.B.  Stika Design can be used with a computer running any screen resolution.  However, at low
resolutions (eg., 640 x 480), the drawing screen may feel cramped, and lines, circles, etc., will seem
coarse.  TechSoft recommend a minimun screen display of 800 x 600 x 256 colours.  (Higher screen
resolutions will also improve the appearance, and enhance the use of many other software pack-
ages such as word processors, spreadsheets, etc.)
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1  INTRODUCTION

About this Manual
In common with most software, Stika Design can be used without further reference to the manual.
Most functions are self-explanatory and Help is always available.  However, to achieve the best
results in the shortest time, it is recommended that you read this manual in its entirety, and careful-
ly work through the tutorials.  This printed manual is intended as a practical guide to using the soft-
ware on a day to day basis, not as a deep technical reference.  For technical reference information
use the Help facilities within the software.

Software Overview
Design Tools consists of a suite of integrated software packages developed to provide solutions for
designers in many different areas.  This software, Stika Design, is part of the Design Tools suite.
(Stika Design is essentially a reduced function version of Design Tools - 2D Design, TechSoft’s
mainstream CAD/drawing package.)  It has been tailored specifically to suit the requirements of
STKA users.  It has a range of appropriate facilities and functions, with dedicated drivers to get the
best out of your STIKA. 

Stika Design can work in a number of different ways.  It is ideal for generating simple banner text,
yet it is also suitable for a wide variety of graphic design work and/or geometrical drawing.
Additionally it has import facilites which allow it to load clipart or images from a wide range of
third party drawing software, so that they may be processed for output.
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2  INSTALLATION

Please follow the instructions below carefully for problem free installation.

The installation set supplied consists of a CD ROM and a floppy disk.  The floppy disk contains
your registration details and will be required during installation.  Keep this disk safe, as it may be
required for future upgrades.

The release CD ROM allows direct installation onto your target computer.  If your target computer
does not have a CD ROM drive fitted, the CD may be used with any computer that does have a
suitable drive, to create an installation set of floppy disks.  These floppy disks can then be used to
install the software on the target computer.

Microsoft Windows 95/98, NT, etc., Users Only
On insertion of the CD into the drive the installation program will normally auto-start.  If for any
reason the installation disk fails to start automatically, choose Start > Run, then type d:\setup (adapt
this as appropriate if using a CD ROM drive other than d) and press ENTER.

Microsoft Windows V3.1x Users Only
Insert the CD into the drive, and from the Program Manager choose File > Run, then type d:\setup
(adapt this as appropriate if using a CD ROM drive other than d) and press ENTER.

All users
When the install program starts, a splash window similar to that below will be displayed.

If installing directly onto the computer in use, choose the Install NOW from CDbutton, then follow
the on-screen prompts.

If you wish to create a floppy disk installation set, choose the Create floppy install disksbutton
then follow the on-screen prompts.  When the floppy disk set has been created, refer to the section
Installation from floppydisks below.
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Installation from floppy disks

Microsoft Windows 95/98, NT, etc.
1. Insert disk 1 in a floppy drive.
2. Choose Start > Run.
3. Type a:\setup (adapt this as appropriate if using a floppy drive other than a) and press ENTER.
4. Follow the on-screen instructions. 

Microsoft Windows V3.1x
1. Insert disk 1 in a floppy drive.
2. From Program Manager choose File > Run.
3. Type a:\setup (adapt this as appropriate if using a floppy drive other than a) and press ENTER.
4. Follow the on-screen instructions.

3  STARTING THE PROGRAM

16 Bit Version (Microsoft Windows V3.1x)
Double click on the Stika Design icon in the TechSoft Design Tools group.

32 Bit Version (Microsoft Windows 95/98, NT)
Choose Start> Programs> TechSoft Design Tools> Stika Design, or use the desktop shortcut icon.

4  DESIGN TOOLS HELP
Help is a standard Windows feature supported by a wide range of software.  Design Tools Help
gives you easy access to detailed information on every menu item, tool, dialog box, button and fea-
ture in Stika Design.

You can access Help in the following ways:

1. Use Help > Help Topics.
2. Click on the Help button in a dialog box for help on that dialog box.
3. With any menu item highlighted, press the F1 key to see a Help window describing that menu

item.
4. Press Shift + F1 to display the Help cursor.  Then click on any tool to see a Help window

describing it.
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5  TUTORIALS

TUTORIAL 1 - Screen layout, menu selection, etc.
The STIKA Design program window provides a clear view of the current drawing, material size,
various information areas, and a selection of icons with tools to cover the most common drawing,
editing, and display functions.

1. Start up Stika Design (see Starting the Programpage 5) and familiarise yourself with the
screen layout as shown below:

2. Menu items are normally chosen from the menu bar or the toolbox, using the mouse (although
many keyboard alternatives are available).  To choose an item from the toolbox, position the
pointer over the appropriate icon and click the LH mouse button.  Some items in the RH tool-
box (the Drawing Aids toolbox), such as Grid, will cause the icon to stay selected (on) until it
is chosen again.  
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Absolute coordinates show
the position of the cursor rela-
tive to the drawing origin (the
bottom LH corner of the draw-
ing area)

Relative coordinates show
the position of the cursor
relative to the last point
located, or object drawn
(can be reset by pressing
SPACE bar)

Relocatable drawing aids
toolbox has a range of
commonly used functions

The grey dotted rectangle
represents the working
area of the STIKA

Allows the setting of line
type (solid, dotted, etc),
thickness and colour

Allows the setting of a range of
fill/hatch parameters, eg.,
colour, line spacings/type, etc.

Simple prompts always
tell you what to do next

Toolbar help explains
each icon

Relocatable draw/edit
toolbox allows easy
access to all the main
draw/edit functions

Pull out toolbar.  Just
select a toolbox icon,
and hold down the LH
mouse button to open
the toolbar

Distance from last shows
the distance from the last
point located or drawn

Angle from last shows the
angle from the last point
located or drawn

The white area represents
the actual size of the
material being used

Optional title bar help mes-
sage.  (Can be relocated at
the bottom of the screen)



3. Many of the items in the LH toolbox (the Draw/Edit toolbox) have pull out toolbars.  These
are activated by positioning the pointer on the icon then pressing and holding the LH mouse
button for a short while.  The pointer can then be dragged along the icon bar until the required
icon is highlighted, then the mouse button released.  This selects the item, and changes the
icon in the toolbox to that chosen.

4. Most menu items, eg., text, grid, etc., have a related dialog box for settings.  To access these
dialog boxes, double click on the appropriate icon with the LH mouse button, or click on the
icon with the RH mouse button.

TUTORIAL 2 - Setting up the software to suit your system
During the course of this tutorial you will set the cutting area of your STIKA to suit your normal
sign cutting requirements.  You will then save these values as the default.

1. Start up Stika Design.  Select Setup > Layout and ensure that the software is set to suit your
particular model of STIKA.

2. Set a length of material and an orientation most suitable to the type of work you will normally
be doing, then click OK to close the dialog box.  

The proportions of the screen may change to reflect the new values.

3. Select Setup > Set as default. Click OK on the warning dialog box.  Close down the software
completely, then restart it.  You will see that it starts up with the settings you have made.
(Any other settings made from the Setupmenu, eg., grid spacing, will also be saved.)

N.B.  If you ever wish to return to the factory default settings, select Help > Restore Factory
Defaults, then Setup > Set as default.
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TUTORIAL 3 - Setting up the STIKA and cutting a sample
During the course of this tutorial you will create a simple text drawing and cut out the design.

1. Start up Stika Design.  Choose Setup > Layout, ensure that the software is set to suit your par-
ticular model of STIKA, and note the material size values.  Click OK to close the dialog box.
The drawing screen should now look something like the illustration below (it will vary accord-
ing to the model of STIKA chosen).  You will notice a grey dotted rectangle inside the white
vinyl area - this is the actual cutting area of your STIKA.

2. Ensure that your STIKA is connected to the computer, is powered up, and a suitable piece of
vinyl (the size specified in the Layoutdialog box) is inserted ready to cut.  (For the STX-7,
load the material and ensure that the green light is on by pressing the button on the machine.
For the SCP-85, ensure that the picture LED is off, then insert the material and wait until it
has stopped feeding through.)

3. Choose the Linear texticon.
At the prompt Locate start position for text, move the cursor to a position approximately
10mm (1 grid space) to the right of the left edge of the grey dotted inner box, and 40mm (4
grid spaces) down from the top edge of the grey dotted inner box, then click the LH mouse
button.  The following dialog box will open.

Page 8 DESIGN TOOLS - Stika Design



Type in  “STIKA” then click on the Settingsbutton.  The following dialog box will open.

Ensure that the font is set to Arial - Bold (if not available choose another font), and change the
Height to 30.  Click OK on the Text settingsdialog box, then OK on the Text entrydialog box.

4. Choose File > Plot.  From the dialog box click on the Connectionbutton.  Check that the con-
nection is set correctly for the device and the computer port that you are using (eg., STIKA
STX-7 would normally use LPT1, STIKA SCP-85 would normally use COM1 or COM2).
(For details of output Via Generic / Text Only Printer driver, see Connectionpage 22.)  Close
the Connectiondialog box.

5. Click OK on the Plot dialog box.  The sign should now be cut.
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TUTORIAL 4 - Basic Drawing, ie., lines, circles, arcs, curves, etc.

1. Choose the Single Linesicon.
Move the cursor around, over the white area.  (N.B.  You can draw over the blue area, but it
will not be output.)  Notice the changing coordinates at the bottom of the screen.  Move the
cursor to a position where you wish to start a line, and click the LH mouse button.  A moving
line should now appear.  To “finish” a line click the LH mouse button again.  Carry on draw-
ing a few more lines.  (To help with this tutorial, ensure that some of them cross each other.)

2. Choose the Connected Linesicon from the Linestoolbar.
Move the cursor to a start point, and click the LH mouse button.  To “fix” a line section, click
the LH mouse button again.  A new moving line should now appear from the end of the fixed
line.  To “finish”, either double click the LH mouse button (this will “fix” the moving line), or
click the RH mouse button (this will finish at the last fixed line).  Try drawing a few lines fin-
ished in different ways.  You will notice that although a grid is showing, the lines are not start-
ing and ending on grid positions.

3. Choose the Grid Lock icon.
Now draw a few more lines.  The ends of the lines will now be fixed to grid positions.

4. Choose the Step Lockicon.
Now draw a few more lines.  Again the ends of the lines appear to be free.  However, they are
not entirely free as will be seen after the next two steps.

5. Choose the Zoom inicon.
Note the prompt reading Locate one corner of zoom box.  Move the cursor approx. 1 grid
square (10mm) below and to the left of any “corner” that you have drawn, then click the LH
mouse button.  The prompt will change to Locate opposite corner of zoom box.  Move the
mouse to pull out a box up to the right, about 30mm square (three grid squares), then click the
LH mouse button.  That area will now be redrawn to fill the screen. 

6. Choose the Connected Linesicon again.
Draw some more lines.  Notice that when the mouse moves, the cursor moves in small steps
between the grid dots.  In fact the default step spacing is 1mm.

7. Choose the Step Lockicon again.
This time step lock will be deselected and the cursor will be free to move to any position.
Thus, there are three lock options, grid lock, step lock, and no lock.
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8. Choose the Zoom Lasticon from the Zoom toolbar.
This will restore the previous zoom level, in this case the full drawing screen.  (You might
also like to try the effects of theZoom+and Zoom-icons in the RH toolbox at this point.)
Choose the Connected Linesicon again and draw the first point of another line.

9. Choose the Radial Lockicon.
Any line drawn is now constrained to 45 deg steps.  Double click on this icon with the LH
mouse button and a dialog box will appear.  This allows the start angle and step angle to be
set.  Try the effects of different settings.  Many other icons have dialog boxes accessed in the
same way.  Alternatively, dialog boxes may be accessed by clicking with the RH mouse but-
ton.  Try clicking on the Grid icon with the RH mouse button.  

10. Choose the Single Linesicon again and draw a few lines.

11. Choose the Attachicon and ensure that Grid Lockand Radial Lockare off.
The cursor will change to a small square.  Position the cursor square to overlap the end of any
line, and click the LH mouse button.  The start of the line being drawn will automatically start
exactly from the end of the selected line.  Position the cursor over the end of a different line,
and click the LH mouse button again.  You do not have to be absolutely accurate in your posi-
tioning, as long as the square is over the line.  It is possible to change the size of the attach
box and the points being attached to, from the attach dialog box (double click on the icon).
Try setting attach to intersections as well as end points, and try drawing lines between inter-
sections.  Remember, just make sure that the intersection is inside the attach box.

12. So far you have only drawn lines.  Try some of the other drawing functions - circles, arcs,
shapes and paths.  Follow prompts, and use Help for further explanation.

13. Try deleting and undoing as described below.
Simple mistakes may be undone by clicking on the Undo lasticon in the RH toolbox.  This
undoes the last operation, either drawing, transforming or deleting.  Once undone, the icon
becomes Redo last.  Choosing this effectively undoes the undo.  Redo lastis cleared by any
further drawing or deleting operation.  Also in the RH toolbox is Delete last.  This deletes
back one object each time it is chosen.  Undo lastrestores a deleted object, but only the last
one deleted!  Most other delete functions are in the LH toolbox, where there is Delete any,
Delete part, and Delete inside box.  Delete anyallows you to point to an object and delete it.
Delete partdeletes any part of a line, arc, circle or bezier curve back to the closest intersection
points to the locating point.  Finally, pressing Ctrl + Deleteon the keyboard deletes the cur-
rent selection (selection will be dealt with in Tutorial 5), pressing  ALT + Deleteon the key-
board deletes the whole of the current drawing.  Try some of the Deleteoptions now.
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TUTORIAL 5 - Object selection and the marquee box
As you will see in this tutorial, selection is carried out using normal Windows methods.  Selected
objects may be dragged, rotated, flipped, resized or copied quickly and easily.

1. Start up Stika Design, or if you have already loaded the program, choose File > Closeto clear
any work you have done so far.  Choose File > Openand load the drawing “Sammy” from the
Tutorial directory. 

2. Choose the Selecticon.
Move the cursor below, and to the LH side of Sammy.  Press the LH mouse button, drag a box
around the drawing, then release (alternatively Select Allusing the keyboard shortcut Ctrl +
A).  Sammy will be redrawn in pink, and surrounded by a dotted box (a marquee box) with
handles (yellow shapes). 

3. Familiarise yourself with the marquee box functions, as described below.

The large centre square handle allows the box to be re-positioned.  Clicking on the handle
with the LH mouse button allows the box to be moved around (Grid Lockand Attachstill
operate).  A second click with the LH mouse button “drops” the box in its new position (or a
second click with the RH mouse button cancels the operation.)
N.B.  If the initial click is done with the RH mouse button, the handle will move and not the
box.  Subsequent operations such as flip and rotate will act about this handle.  When the mar-
quee box is de-selected, the centre handle will revert to its normal position.



The corner and edge square handles allow the box to be re-sized.  Clicking with the LH
mouse button allows the handle to move, clicking again redraws the object/s at the new size. 
N.B.  Warning - moving the corner and edge handles can alter the aspect ratio.  In this case,
arcs and circles are converted to elliptical bezier curves, which can no longer have tangency
properties, etc.  Clicking in a corner handle with the RH mouse button, then moving, main-
tains the aspect ratio, keeping circles and arcs fixed (this may however, change the drawing
layout).  

The circular handle to the right of the marquee box allows the object(s) to be rotated.  
N.B.  This can be used in conjunction with the Radial Locktool.  

The diamond handles, above and to the left of the the box, flip the object(s) vertically or hori-
zontally, and the double handle below the box copies the object(s), leaving the new copy
selected.  

Experiment with these handles to test the effects.  
N.B.  To undo a transformation (or any other drawing or editing operation), click on the Undo
last icon in the RH toolbox.

4. An individual object (single line, arc, etc.) can be selected by moving the pointer near it and
clicking the LH mouse button.  Clicking on another object in the same way will select the new
object (de-selecting the first object).  Clicking on an object with the RH mouse button (or
SHIFT + LH mouse button) will "add" or "remove" the object from the selection by toggling
its select state.

Multiple objects can be selected by dragging a select box around them with the LH mouse
button.  Dragging another select box in the same way will create a new selection (cancelling
the first).  Dragging a select box with the RH mouse button (or SHIFT + LH mouse button),
will toggle the select state of the objects.

To de-select objects, move the pointer outside the marquee box and click the LH mouse but-
ton.  Individual objects may be de-selected using the RH mouse button (or SHIFT + LH
mouse button) as described above.  

Try all of the above options on Sammy to get the feel of the selection process.
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TUTORIAL 6 - Editing the drawing
Selected objects may also be easily edited (start/end/centre/nodes of lines/arcs/paths/text, etc.,
moved and modified). 

1. Start up Stika Design, or choose File > Closeto clear any work you have done so far.  Choose
File > Openand load the drawing “Sammy” from the Tutorial directory.  Select the upper
straight line forming Sammy’s tail.  You will notice the Property/Start Edittoolbox open in
the bottom RH corner of the screen. 

Click on the Start Editbutton.

The line will turn grey, and a red and green circle will appear at the ends.  These are the nodes
of the line (defining points), green indicates the start point, red the end point.  Click on the
green node using the LH button.  The node will now follow the mouse freely around.  Click
again and the line will be repositioned at that point.  Click on Undo Lastto return the line to
its original position.  Now click on the green node using the RH button.  The line will still
move, but is now constrained along its own path.  Click again to place the line, then click on
Undo Lastto return the line to its original state.  To remove the nodes, click “off” the drawing,
(or click on End Edit).  This will return the marquee box.  Click off again to de-select.  

2. Now select Sammy’s back curve and then click on Start Edit.

The curve will grey, and circles will appear on it to denote the nodes.  (In this case these
points are the original location points when the curve was drawn, green - start, red - end, and
orange for all other defining points).  Each node has two yellow handles (only one for the start
and end points).  Clicking on a node or a handle with the LH button allows that point to be
moved around.  Clicking on one of a pair of handles with the RH button, locks the angle of
the handles and allows them to move together.  Try it.
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3. You may have noticed that as Start Editis selected, it is replaced by a longer option
menu (so far with all the options greyed out).  To activate these options, a node or
line/curve section must be selected.  To select a line/curve section, just move the
cursor near it and click LH (or RH) as usual.  The easiest way to select a node is to
drag a select box over it (LH or RH as usual).  Alternatively, click on it using
CTRL+LH (or RH) (just clicking on it selects it to move).  Options will become
available according to what is selected.  There are too many permutations to go
through them in detail, just experiment!

4. By now Sammy may be a bit of a mess.  Select End Edit, close your drawing, and
re-load “Sammy” again.  Select the whole drawing, then click on Start Edit.  As
you will see it is possible to edit several objects at once.

Drag a select box over Sammy’s tail as shown below.

It is now possible to move the whole tail section by clicking on one of the selected nodes and
moving with the mouse.

In this way, very powerful editing changes can be made very easily.
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TUTORIAL 7 - Line types, Colours and how to fill
When outputting to STIKA in cutting mode, filled areas will only have their outline cut, thick lines
will be cut as if thin, and normally all colours will be output.  It is possible to output colours indi-
vidually (see Pens/Toolspage 23).  If cutting, the ability to show coloured fills is purely to help
visualisation.  

When outputting to the STX-7 only, it is also possible to use pens to plot out (see Pens/Toolspage
23).  In this case, filled areas and thick lines can be filled using a plotter pen.

Familiarise yourself with how to change line style/colour or solid/hatched fill, as described below:

1. So far, all the drawing done (if you are following these tutorials closely!) will be in solid black
lines with no fills.  To set a different line style/colour or a solid/hatched fill, new parameters
are set from the attributes bar at the top of the screen.

Simply click on the appropriate button to change the attributes from a dialog box.  If the line
settings are changed to, say, dashed with colour red, all subsequent lines will be red dashed
lines.  If the fill settings are changed to, say, colour blue, solid fill, all subsequent closed
shapes (eg., circles, rectangles, closed paths, etc.,) will be filled in blue.  Try it.

It is also possible to change the colour/line style/fill of an object after it has been drawn.  This is
done as follows:

2. Choose the Selecticon.
Move the cursor over any filled object and click.  The object will be redrawn in pink, and sur-
rounded by a dotted box (a marquee box) with handles (yellow shapes).  (We explored the
marquee box in Tutorial 5).  Notice how the information boxes on the attributes bar have
blanked out, as shown below.

Click the Fill Col...button and change the fill colour to a different colour.  Click OK, then
click anywhere away from the drawing.  The object will turn to the new colour.  In a similar
manner, we could have altered, not only the fill colour, but also the fill type and the line
style/colour, etc., as well.  This is useful for changing from solid to outline, etc. 
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TUTORIAL 8 - Text
The text functions are very comprehensive.  Text fonts used are in Windows TrueType format.  Vast
numbers of fonts in this format are cheap and widely available.  There are three basic text func-
tions,Linear text by variablewhich allows the user to set all variables, font, sizes, spacings,
colours, etc; Linear text by boxwhich allows the user to pre-define font, colour, etc., then to apply
the text to a user defined box; and Text along a pathwhich allows text to flow around the outside
or inside of a selected path object (normally a circle, arc, polygon or bezier curve).

1. Start up Stika Design, or choose File > Closeto clear any work you have done so far then
choose File > Newto start a new drawing.  For the purposes of this tutorial only, choose Help
> Restore factory defaults.

2. Choose the Linear texticon.
At the prompt Locate start position for text, move the cursor to position (30, 40) approx., then
click the LH mouse button.  The following dialog box will open.

Type in Techsoft “R” CAD then click on the Settingsbutton.  The following dialog box will
open.

Ensure that the font is set to Arial - Bold (if not available choose another font), change the
Height to 12, and the Fill Col... to blue.  Click OK on both dialog boxes.
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Your text should appear as below.

3. Select the text (so that it has a marquee box around it).  You will notice the
Property/Start Edittoolbox open in the bottom RH corner of the screen.

Click on the Propertybutton.  The Text entrydialog box will open as below.

Edit the text to change the letter S to a capital.  Highlight the three characters “R” (drag the
text cursor over the characters so that they are highlighted in blue).  Click on the Settingsbut-
ton.  In the Text settingsdialog box set the Height to 17, and the Fill Col... to red.  OK all
dialogs, then click off to de-select the text.  Your text should appear as below.

4. Select the text again, click on the Propertybutton, and highlight the single character R in the
Text entrydialog box.  Click on the Settingsbutton, then in the Text settingsdialog box, click
on the Charactersbutton.  The following dialog box will open.



Set the Flippedoption on.  OK all dialogs, and click off to de-select the text.  Your text should
appear as below.

5. Repeat the process to select the three characters CAD.  From the Character Effectsdialog
box, set the slantangle to 20 degrees.  Now highlight the word TechSoft and set the slant
angle to -20 degrees.  Your text should appear as below.

6. This example demonstrates just some of the powerful text facilities available.  There are often
several ways of achieving the same ends.  In fact, the above outcome could also have been
achieved by drawing the text “straight”, exploding it (Edit > Explode), then using the transfor-
mation tools.  There are no rights or wrongs here, experience will finally be the guide as to the
best working methods for you.

Close the current drawing, then open the drawing “textdem” and observe some of the many
other possible text effects.  (Do not attempt to output this drawing, it is for observation only!) 

The “textdem” file raises an important point regarding the transfer of files.  Stika Design uses
Windows TrueType fonts.  As drawings are created, edited, re-drawn, etc., the software refers
back to the TrueType font data stored in the computer.  If a drawing is saved and then loaded
onto another computer, the text can only be reproduced correctly if the fonts used are installed
on the second computer.  If the fonts are not found, Windows automatically substitutes an
alternative.  The “textdem” file contains a variety of fonts unlikely to be found on your com-
puter.  To be able to display them correctly, all text was first selected, then “exploded” using
the menu item Edit > Explode.  This converts the text to a series of individual letter “shapes”
(paths).  Although the text properties are lost, the shape of each letter can now be modified
using Start Edit, a useful feature in its own right.

(N.B.  Redrawing exploded text can be much slower than redrawing normal text, so text
should only be exploded when really necessary.)

7. Try out some of the other text options, eg.,Text along a path.  Follow the screen prompts and
use Help if you need further explanation.
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TUTORIAL 9 - Transformations
You have already tried simple transformations using the marquee box in Tutorial 5.  There are dif-
ferent transformation functions available in the LH toolbox,Move/Copy, Mirror image, Rotate,
Distort, etc.  All these functions operate in a similar way.  First you must select the objects to be
transformed using the Selectoption.  Then choose the appropriate transform option (the objects will
stay selected but the select box will disappear).  Set/check the variables in the dialog box that
appears, then follow the screen instructions.  The following example illustrates their use.

a                                                b                                               c                     

1. Start up Stika Design, or choose File > Closeto clear any work you have done so far. Choose
File > Openand load the “flower” drawing from the Tutorial directory.  (See fig a.)

2. Choose the Selecticon.
Select the leaf only, by clicking next to it, or by dragging a select box over it.

3. Choose the Mirror image icon from the Transformtoolbar.
Ensure that Repeat/Replaceis set to Repeat.  Ensure that Grid Lock is on.  At the prompt
Locate one point on axis of reflection, move the cursor to co-ordinate position (100, 110), then
click the LH mouse button.  At the second prompt Locate another point on axis of reflection,
locate the cursor at co-ordinate position (100, 150).  The drawing should now appear as in
fig b.

4. Choose the Selecticon.
Select the petal only, by clicking next to it, or by dragging a select box over it.

5. Choose the Rotateicon from the Transformtoolbar.
Ensure that Repeat/Replaceis set to Repeat, No. repeatsto 5,Angle of rotationto 60 deg.  At
the prompt Locate centre of rotation, locate the cursor at co-ordinate position (100, 220).  The
finished drawing should now appear as in fig c.
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6  OUTPUTTING
When outputting to the STIKA, first set the screen drawing area to match the material to be used.
To do this chooseSetup> Layout.  From the resulting dialog box set the Stika model and the size
of material to be used.  (See Tutorial 2 page 7.)  If you wish to retain your chosen layout for future
sessions, choose Setup> Set as default.

When you are ready to output, choose File > Plot.  At this time the STIKA should be:

1. Connected to the computer.
2. Plugged in and switched on.
3. Correctly loaded with material, and ready to receive data.

For the STX-7, load a piece of material of a suitable size into the STIKA, and ensure that the
green light is on by pressing the button on the machine.
For the SCP-85, simply insert a piece of material of a suitable length into the STIKA (ensur-
ing first that the picture LED is off), and wait until the material has stopped feeding through.

The Plot dialog box will open in one of the two forms shown below:

Output range
The output range is normally set to All.  If, however, an object or group of objects is selected when
going to output, the range is set to Selection, and if retained, only the currently selected objects will
be output.  This is a very useful feature for selective outputting.
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Connection
The Connectionmay be Direct to port, or Via Generic / Text Only Printer driver.  By default, con-
nection is set to Direct to port.  In this mode all data is transmitted directly to the STIKA.  This is
the simplest option to set up, but will cause the computer to be tied up until output is completed. 

The Via Generic / Text Only Printer driver option makes use of the Windows print buffering capa-
bilities.  The Generic / Text Onlyprinter driver is a neutral printer driver which allows plotter com-
mands to pass directly through it.  It therefore allows direct control of the STIKA, whilst maintain-
ing the advantages of the windows background printing and queueing facilities.  Before using this
option, however, the Generic / Text Onlydriver must be loaded and set as the current printer driver.
The Generic / Text Onlyprinter driver is installed either from Windows 3.1Program Manager
using Control Panel> Printers> Add, or from Windows 95/98, NT, using Start> Settings>
Printers> Add Printer... Manufacturer “Generic” .  The driver itself is supplied on your Windows
installation discs.  Additionally the driver’s setup should have set:Paper size - A4, Paper feed -
Continuous, No Page break.

The STIKA STX-7 has a parallel port.   If the Connectionis set to Direct to porta suitable parallel
port (normally LPT1) must be set.  If the Connectionis set to Via Generic / Text Only Printer dri-
ver, the printer driver itself must be set to a suitable parallel port (normally LPT1).

The STIKA SCP-85 has a serial port.  If the Connectionis set to Direct to porta suitable serial port
(normally COM1 or COM2) must be set.  If the Connectionis set to Via Generic / Text Only
Printer driver, the printer driver itself must be set to a suitable serial port (normally COM1 or
COM2), and the protocol must be set to 9600 baud, 8 data bits, 1 stop bit, No parity, Hardware
flow control.

If you wish to change the connection permanently, the appropriate changes should be made, and
then the setup saved using Setup > Set as default.
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Pens/Tools
This leads to a dialog box which allows you to determine whether all, or just selected colours are
output, and in the case of the STX-7 only, whether a cutter and/or plotting pens are to be used.

As the STIKA is primarily used for cutting, the default Output modeis Cutter only.  In this mode,
areas of solid colour fill, and hatching, are never output, and thick lines are output as thin.  If Cut
by colouris selected, only objects in the selected colour will be cut.  For the STX-7 only, the
Cutter offset(the distance of the cutting tip from the central axis) is set to 0.25mm, and should not
be changed unless using a non-standard cutter.  

For the STX-7, if pen plotting only is required, the Output Modeshould be set to Pens only, and the
dialog box will change as shown below.

Each pen can have a colour, diameter and speed value.  The speed controls the speed of the pen
when drawing.  The diameter value sets the distance apart of the “cross hatch” lines when an area
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is filled (in practise a value about 90% of the diameter value is used to unsure an overlap).  The
colour of the pen determines which pen is used to plot which colours.  The software will look at
each colour in the design and choose the nearest match from the pens available (based on RGB val-
ues).  Pen colours should normally be set to match the pens you have available.  When a pen
change is required, the STX-7 will stop to allow for a manual pen change, under the direction of an
on-screen prompt.

Again for the STX-7 only, if pen plotting and cutting output is required from the same drawing, the
Output Modeshould be set to Pens then Cutter.  The dialog box will change, and may be set as
shown below.

Appropriate colours/pen diameters/pen speeds can be set for plotting, and a colour can be selected
for cutting (the colour selected for cutting will not be plotted).  When a pen/cutter change is
required, the STX-7 will stop to allow for a manual change, under the direction of an on-screen
prompt.  
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HINTS, TIPS & TROUBLESHOOTING for STIKA

1. When using the File > Plot option, a message The Generic / Text Only Printer must be
selected before plotting with this connection can take placeappears.
Refer to Connectionpage 22.

2. When using File > Plot, “it’s not working”, there is no reaction from the STIKA.
The most common cause is incorrect setting up, either from the software or the device itself.
If experiencing problems first check that the Connection(in the File > Plot dialog box) has
been set appropriately and that you are using the correct lead.  

If using the connection Via Generic / Text Only Printer driver, check the installation and set-
tings of the Generic / Text Onlyprinter driver very carefully (particularly with regard to the
com/serial port settings if using the SCP-85).  Refer to Connectionpage 22.

Check that the STIKA has material loaded and is ready to receive data.

3. Erratic output, spurious lines cut, random data errors, random error lights flashing, etc.
On some computers, power management systems have been known to cause outputting errors,
eg., if data is still being transmitted when the monitor, hard disk, etc., is powered down, the
data can become corrupted.  (Power management systems are usually setup in the computer
bios - refer to the computer documentation or supplier.)

General problems can be caused by hardware clashes in your computer, eg., if two or more
devices are set to use the same “hardware interrupts”.  This is more common if extra expan-
sion cards are fitted to the computer, eg., network cards, sound cards, SCSI cards, some CD
roms, etc.  Curing this type of clash may require reference to the supplier of the computer.
(From Windows 95/98, NT, you might try Start> Settings> Control Panel> System> Device
Manager> Ports > Select appropriate port > Properties> General to look for clues.)

4. Random lines cut when using a STIKA SCP-85 from Windows 95/98, NT.
These can sometimes be cured by de-selecting the use of FIFO buffers (from Windows 95/98,
NT, use Start> Settings> Control Panel> System> Device Manager> Ports> Select
Communications Port (COM1)or Communications Port (COM2)as applicable > Properties>
Port Settings> Advanced> de-select Use FIFO buffers).  If this does not cure the problem,
advice from the supplier of the computer should be sought.

5.  Vinyl sheets are not feeding into the STIKA SCP-85 properly.
Try cleaning the lower pinch rollers.
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6. Signwriting vinyl is difficult to weed.
It is normally the depth of cut at fault.  If the cut is too shallow, the vinyl will not cut com-
pletely through.  If the cut is too deep, the paper backing may be cut and will tend to peel off
with the vinyl.

STX-7
Adjust the cutting depth carefully by adjusting the amount of blade extension (as per the
STIKA manual) to give best results.  If the cutting bed is deeply scored (possibly from repeat-
ed cutting with no vinyl!), then the vinyl will be pressed into the groove and it will be difficult
to set a depth accurately.  If this is the case replace the bed.  From the software (File > Plot >
Pens/Tools)it is possible to set the output to pen plotting.  If this has been done, but the
machine is still using a cutter, then the corners may not be cut accurately, resulting in difficult
weeding at corners.

SCP-85
The cutter cap should be used to set the depth of cut.  If this is not used the blade may cut
right through the vinyl and score the bed.  Also, if the vinyl is too short for the design, it may
be ejected and the blade will cut on the bed.  If for any reason, the bed becomes scored, then
the vinyl will be pressed into the groove and it will be difficult to accurately cut to depth.

Vinyl hardens at low temperature and becomes more difficult to cut.  Always try to use vinyl
at room temperature (18 to 24 deg. C).

7. Plotter pens are drying up quickly (STX-7 only).
If pen plotting do not use cartridge, photocopy or similar paper with fibre tip pens.  These
papers are abrasive and highly absorbent - they soon wreck good pens!  Use smooth non-
porous (non, or anti-bleed/absorbent) papers.

8. I’ve tried everything, and it still doesn’t work!
If your STIKA powers up correctly, but still does not work after checking the preceding
points, then (if possible), try running the machine from another computer (preferably a differ-
ent model), and/or with another lead.  (Computers and leads can be faulty as well as
STIKAs!!)  

Techsoft are always pleased to try and offer technical help and support.  However we will be
unable to help with communication/computer problems, except for advice of a general nature.
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7  CLIPART & LINKS WITH OTHER SOFTWARE
Commercial clipart may be loaded directly into Stika Design provided it is in a format accepted by
the File > Import option, eg.,wmf (Windows metafile), dxf (Data Exchange format), plt (HPGL plot
file), aff (Acorn Draw file), etc.  If the clipart is in another format, eg.,cdr, then the image must
first be loaded into a suitable drawing application, then transferred to Stika Design.  Transferring a
drawing from another application into Stika Design can be done in one of two ways:

1. In the other application, save the drawing in a format that Stika Design can import, eg.,wmf,
dxf, etc.  In Stika Design, use File > Import to load the drawing.

2. In the other application,Copythe drawing to the clipboard.  In Stika Design, use Edit > Paste
to load the drawing.

In a similar way Stika Design files can be transferred to other applications using File > Export, or
by copying to the clipboard then pasting into the other application from the clipboard.

The preferred data format for transfer between Windows based drawing packages is wmf (Windows
metafile format) or emf (Enhanced metafile format).

N.B.  Confusion sometimes arises about the use of bitmap images in Design Tools - Stika Design.
See below for details.

Bitmap / Scanned Images
Stika Design only understands drawings in vector format (lines, arcs, etc.).  It does not understand
bitmap (raster) images.  Bitmap images are normally produced in painting packages or from hand-
held or flatbed scanners.  These images essentially consist of pictures made up of small coloured
dots.  (Some clipart is in bitmap format.)  To load images from these sources into Stika Design they
must first be “vectorised”, ie., the coloured shapes in the image must be “traced” around to create
an equivalent vector image.  This must be done in one of several third party pieces of software.  To
confuse the issue slightly, whilst wmf and emf files are primarily used for vector format drawings,
they can also store other drawing data such as bitmap data.  If a wmf or emf file with bitmap data
is loaded into Stika Design, the bitmap part of the data will be ignored (this may lead to a blank
drawing, and the user thinking that loading has “gone wrong”).

N.B.  As a cautionary note, vectorised bitmap images can be excellent, but are often very poor, par-
ticularly when photographic or other complex images are used.  Bitmap to vector conversion is not
an easy option for inexperienced users, and should only be used as a last resort.
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